KBEditor
След.

Редактор раскладки для программируемой клавиатуры

Версия 1.6

Наш сайт: http://www.shtrih-m.ru

Наш форум: http://forum.shtrih-m.ru

Скачать обновления: http://www.shtrih-m.ru/downloads/show_prod_109.html

Обратная связь: http://forum.shtrih-m.ru/viewtopic.php?t=1673

Содержание

1. Клавиатура
1.1. Технические характеристики
1.2. Подключение клавиатуры
1.3. Изображения клавиш
1.4. Режимы работы клавиатуры и индикация состояний
2. Работа с программой
2.1. Меню программы
2.1.1. Меню Файл
2.1.2. Меню Правка
2.1.3. Меню Устройство
2.1.4. Меню Вид
2.1.5. Меню Окно
2.1.6. Меню Справка
2.2. Программирование клавиш
2.2.1. Окно редактирования клавиши
2.2.2. Автоповтор клавиши
2.2.3. Выбор слоя
2.2.4. Функция клавиши
2.2.5. Назначение скан-кодов
2.2.6. Установка звукового сигнала
2.2.7. Установка примечания
2.3. Копирование и перемещение клавиш
2.3.1. Перемещение клавиш
2.3.2. Копирование клавиш
2.4. Программирование ключа
2.5. Программирование считывателя
2.5.1. Считыватель магнитных карт
2.5.2. Префиксы и суффиксы
2.5.3. Установка звукового сигнала
2.6. Группы клавиш
2.7. Редактирование изображений клавиш
3. Работа с клавиатурой
3.1. Информации о клавиатуре
3.2. Тест клавиатуры
3.3. Чтение раскладки
3.4. Загрузка раскладки
3.5. Запись программы
4. Приложения
4.1. Список нот
4.2. Комплектация
4.3. Представление скан-кодов
5. Контактная информация

1. Клавиатура

1.1. Технические характеристики

Программируемые клавиатуры отличаются количеством клавиш, наличием ключа и считывателя магнитных карт. Буква “K” в названии модели клавиатуры означает наличие ключа, буква “R” – наличие считывателя магнитных карт.

Таблица 1. Выпускаемые модели

Модель | Количество клавиш | Ключ | Считыватель магнитных карт
KB-60K | 60 | Есть | Нет
KB-60RK | 60 | Есть | Есть
KB-64K | 64 | Есть | Нет
KB-64RK | 64 | Есть | Есть
PKB-64R | 64 | Нет | Есть
KB-112RK | 112 | Есть | Есть

1.2. Подключение клавиатуры

Подключение программируемой клавиатуры к компьютеру показано на рисунке 1. Программируемая клавиатура подключается к порту PS/2 компьютера. Обычная клавиатура подключается к порту PS/2 программируемой клавиатуры.

Рисунок 1. Подключение клавиатуры

1.3. Изображения клавиш

Существует возможность задать изображения для клавиш клавиатуры. Для этого нужно снять съемный прозрачный колпачок крышечки, вложить в него изображение и установить его на место. В редакторе раскладки существует возможность создания изображений клавиш. Эти возможности программы описаны в разделе Редактирование изображений клавиш.

Рисунок 2. Крышечка со съемным прозрачным колпачком

Крышечка со съемным прозрачным колпачком

1.4. Режимы работы клавиатуры и индикация состояний

В программируемой клавиатуре есть 2 программы: загрузчик и рабочая программа.

  • Загрузчик предназначен для записи в память клавиатуры раскладки или программы. Перезаписать загрузчик клавиатуры можно только с помощью программатора. Обычно это не требуется пользователю.

  • Программа клавиатуры исполняет загруженную в клавиатуру раскладку и посылает в соответствии с ней скан-коды при нажатии или отжатии клавиш. Перезаписать программу клавиатуры можно с помощью редактора раскладок. Для этого нужно выбрать пункт Записать программу из файла меню Устройство.

Программируемая клавиатура может находиться в одном из двух режимов работы:

  • режим загрузчика

    В этом режиме происходит запись раскладки или рабочей программы в клавиатуру. Когда клавиатура находится в режиме загрузчика, то горят все четыре светодиода слоев.

  • рабочий режим

    В рабочем режиме клавиатура посылает указанные в раскладки скан-коды при нажатии или отжатии ее клавиш. Когда клавиатура находится в этом режиме, то горит только один светодиод, соответствующий текущему активному слою.

После записи раскладки в клавиатуру рабочая программа проверяет версию раскладки и ее контрольную сумму. Если версия или контрольная сумма неверны, то раскладка работать не будет. Признаком того, что раскладка не работает являются мигающие по очереди индикаторы слоя.

Такая проблема может возникнуть в трех различных случаях:

  • Если вы записали в клавиатуру раскладку с помощью одной из предыдущих версий программы KBEditor.

    В этом случае устранить проблему можно записав эту же раскладку в клавиатуру с помощью последней версии программы KBEditor.

  • В клавиатуру была записана новая программа, но раскладка осталась старая. Программа клавиатуры проверяет версию раскладки и сигнализирует об ошибке. В этом случае устранить проблему можно так же, как и в первом случае.

  • Если вы записали в клавиатуру с устаревшей версией программы раскладку с помощью текущей версии KBEditor'а.

    В этом случае надо записать последнюю версию программы в клавиатуру с помощью KBEditor'а. Последнии версии программ клавиатуры лежать в каталоге установки KBEditor'а в директории Программы.

След.
2. Работа с программой


2. Работа с программой
Пред. След.

2. Работа с программой

2.1. Меню программы

Рисунок 3. Основное окно программы

Основное окно программы

2.1.1. Меню Файл

  • Создать. Создание новой раскладки. При выборе данного пункта меню появляется окно «Создание новой раскладки», в котором требуется выбрать модель клавиатуры, для которой нужно создать раскладку. Выбор может осуществляться как автоматически (при подключенной клавиатуре), так и вручную из предложенного списка поддерживаемых моделей клавиатур.

    Рисунок 4. Окно мастера создания новой раскладки

    Окно мастера создания новой раскладки

  • Открыть. Открытие для редактирования уже имеющейся раскладки.

  • Сохранить. Сохранение раскладки.

  • Сохранить как. Сохранение раскладки под другим именем.

  • Закрыть. Закрытие текущей раскладки.

  • Закрыть все. Закрытие всех открытых раскладок.

  • Предварительный просмотр. Предварительный просмотр набора картинок текущей раскладки, который будет выведен на печать (доступна только в режиме отображения – «Показать рисунок»)

  • Печать. Печать изображений клавиш текущей раскладки.

  • Выход. Выход из программы.

2.1.2. Меню Правка

  • Вырезать. Вырезать выделенные клавиши.

  • Копировать. Копировать выделенные клавиши.

  • Вставить. Вставка вырезанных или скопированных клавиш.

  • Выделить все. Выделение всех клавиш.

  • Очистить. Удаление выделенных клавиш.

  • Сгруппировать. Группировка выделенных клавиш.

  • Разгруппировать. Отменяет действие команды Сгруппировать.

  • Считыватель магнитных карт. Вызов окна Считыватель магнитных крат.

  • Ключ клавиатуры. Вызов окна Ключ клавиатуры.

  • Свойства раскладки. Показывает окно, в котором можно изменить модель клавиатуры для текущей раскладки.

  • Проверить раскладку. Проверка раскладки на правильность последовательностей скан-кодов.

2.1.3. Меню Устройство

  • Информация об устройстве. Получение информации о подключенной клавиатуре.

  • Тест клавиатуры. Выводит окно, в котором вы можете проверить правильность посылаемых клавиатурой скан-кодов.

  • Записать раскладку. Загрузка раскладки в клавиатуру.

  • Прочитать раскладку. Считывание раскладки из клавиатуры.

  • Прочитать раскладку в файл. Считывание раскладки из клавиатуры в файл.

  • Записать раскладку из файла. Загрузка раскладки в клавиатуру из файла.

  • Записать программу из файла. Загрузка в клавиатуру программы из файла.

  • Установить драйвер клавиатуры. Установка драйвера для доступа к программируемой клавиатуре.

  • Удалить драйвер клавиатуры. Удаление драйвера для доступа к программируемой клавиатуре.

  • Перевести в режим загрузчика. Переводит клавиатуру в режим работы загрузчика.

  • Перевести в рабочий режим. Переводит клавиатуру в рабочий режим.

Подробнее о режимах работы клавиатуры вы можете узнать из раздела Состояние клавиатуры и режимы работы

2.1.4. Меню Вид

  • Отображаемые уровни. Позволяет выбрать текущий слой для работы.

  • Панели инструментов. Позволяет выбрать панели инструментов, которые будут отображаться.

  • Подписи к кнопкам. Позволяет выбрать, будут ли отображаться подписи к кнопкам панели инструментов.

  • Режим отображения. Позволяет выбрать один из режимов, в котором будет отображаться раскладка клавиатуры:

    • «Показать раскладку» (полное отображение скан-кодов нажатия/отжатия клавиши; «+» соответствует нажатию клавиши, «-» - ее отжатию).

    • «Упрощенный вид раскладки» (упрощенное отображение последовательностей нажатий клавиш на стандартной клавиатуре).

    • «Показать рисунки» (переход в режим работы с редактором накладок на клавиши клавиатуры – смотрите раздел Назначение рисунков и надписей клавишам клавиатуры).

2.1.5. Меню Окно

  • Расположить вертикально. При работе с несколькими открытыми раскладками, редактор расположит окна в ряд.

  • Расположить горизонтально. При работе с несколькими открытыми раскладками, редактор расположит окна столбцом.

  • Каскадом. При работе с несколькими раскладками расположит окна редактирования каскадом.

2.1.6. Меню Справка

  • О программе. Выводит окно информации о программе.

  • Поддерживаемые устройства. Выводит окно со списком поддерживаемых устройств.

  • Проверить обновления. Проверяет наличие новой версии редактора на сервере и выводит окно с изменениями в этой версии.

  • Вызов справки. Вызывает данное окно со справкой о программе.

2.2. Программирование клавиш

2.2.1. Окно редактирования клавиши

Окно редактирования клавиши - основной инструмент программирования клавиш клавиатуры. В нем осуществляется назначения скан-кодов для клавиш, задание примечания и звукового сигнала.

Рисунок 5. Окно редактирования клавиши

Окно редактирования клавиши

Открыть окно редактирования клавиши можно двойным кликом на нужной вам ячейке, выбрав пункт Свойства контекстного меню или нажав на кнопку Свойства на панели инструментов.

Существует возможность редактирования сразу нескольких клавиш, для этого необходимо выделить те клавиши, которые вы хотите редактировать и открыть для них окно редактирования.

В заголовке окна редактирования будут указаны координаты клавиши или диапазон координат, если вы редактируете несколько клавиш.

При редактировании нескольких клавиш в окне редактирования заполненными окажутся только те поля, в которых у всех клавиш были одинаковые данные. Те поля, где данные были разными окажутся пустыми.

2.2.2. Автоповтор клавиши

Флаг Автоповтор клавиши отвечает за то будет ли клавиша клавиатуры повторять посылку скан-кодов, если ее держать нажатой. Если этот флаг отмечен, то клавиша будте посылать скан-коды все то время, пока она остается нажатой. В противном случае клавиша пошлет скан-коды только один раз во время нажатия.

2.2.3. Выбор слоя

В окне редактирования вы можете выбрать слой раскладки, для которого вы хотите задать данные. Для этого выберите нужный вам слой из списка в левой части окна редактирования. Вы можете задавать разные данные в разных слоях для одной и той же клавиши.

2.2.4. Функция клавиши

Из списка Функция клавиши вы можете выбрать какую функцию будет выполнять данная клавиша.

Макрос означает, что клавиша будет посылать скан-коды при нажатии и/или отжатии.

Кроме макроса клавише можно так же задать функцию перехода на слой. Предусмотрены следующие переходы на слой вверх, вниз, переход на конкретный слой и временный переход на конкретный слой (пока нажата клавиша перехода).

[Предостережение] Предостережение

В случае перехода на отсутствующий слой клавиша перехода работать не будет. Например если в клавиатуре есть только 2 слоя, а переход осуществляется на 4-й.

В раскладке ячейки переходов на слои изображаются следующим образом.

  • Зеленая стрелка с цифрой - переход на слой, которому соответствует цифра.

  • Стрелка вверх красного цвета - временный переход на слой, которому соответствует цифра.

  • Стрелка синего цвета без цифры - переход на слой вверх или вниз, в зависимости от направления стрелки.

2.2.5. Назначение скан-кодов

Поля При нажатии и При отжатии позволяют задавать последовательности скан-кодов, посылаемых клавишей клавиатуры при нажатии и отжатии соответственно.

Задать скан-коды для клавиши можно следующим образом:

c помощью клавиши [image] или пункта контекстного меню Добавить коды нажатия и отжатия откройте окно ввода скан-кодов. Выберите стандартную клавишу, или введите свою последовательность скан-кодов. В случае если вы хотите добавить только коды нажатия(make коды) или коды отжатия(break коды), выберите пункт контекстного меню Добавить коды нажатия или Добавить коды отжатия соответственно.

Коды клавиш отображаются в ячейках раскладки в следующем формате:

[+,-][Обозначение клавиши]

“+” означает нажатие, “-“ – отжатие.

Таблицу обозначений клавиш смотрите в Приложении 3.

2.2.6. Установка звукового сигнала

Поле Звук служит для установки звукового сигнала для клавиши. Формат записи звукового сигнала: X;Y;Z ,где X –это нота, Y- длительность в десятках миллисекунд, Z – громкость звукового сигнала в процентах (100 - максимум, 0 -минимум). Список нот смотрите в Приложении 1.

Для задания звукового сигнала клавише необходимо

  1. С помощью клавиши [image] перейти к окну редактирования звукового сигнала.

  2. В появившемся окне вы можете ввести свою последовательность нот или открыть уже готовую последовательность, сохранить и прослушать последовательность нот.

2.2.7. Установка примечания

В поле Примечание вы можете записать примечание для клавиши. В нем можно написать пояснения к тому, что делает та или иная клавиша клавиатуры. Примечание никак не влияет на раскладку и отображается только в окне редактирования клавиши.

2.3. Копирование и перемещение клавиш

2.3.1. Перемещение клавиш

Чтобы переместить клавишу или несколько клавиш

  1. Выделите клавиши, которые вы хотите переместить.

  2. Выберите пункт Вырезать меню Правка или контекстного меню.

  3. Выделите область, куда бы вы хотели вставить вырезанные клавиши.

  4. Выберите пункт Вставить меню Правка или контекстного меню.

[Предостережение] Предостережение

В режиме редактирования одного слоя раскладки перемещается только содержимое редактируемого слоя. Ячейки перехода на слой перемещаются целиком.

2.3.2. Копирование клавиш

  1. Выделите клавиши, которые вы хотите копировать.

  2. Выберите пункт Копировать меню Правка или контекстного меню.

Аналогично можно Вырезать или Удалить клавиши.

[Важно] Важно

Если в буфер скопирована группа клавиш и выделена группа клавиш для вставки, то программа вставит в раскладку только те клавиши, которые попадают в пересечение скопированной и выделенной областей.

[Важно] Важно

Если в буфер скопирована одна клавиша и выделена группа клавиш для вставки, то программа размножит скопированную клавишу по всей выделенной группе.

2.4. Программирование ключа

Рисунок 6. Окно Ключ Клавиатуры

Окно Ключ Клавиатуры

Ключ клавиатуры может посылать последовательности скан-кодов при повороте. Кроме того, существует возможность программирования переходов на различные слои при различных положениях ключа. Можно назначить последовательности посылаемых скан-кодов для каждого положения ключа в любом слое раскладки.

Задать данные для ключа можно в окне Ключ Клавиатуры. Чтобы открыть это окно выберите пункт Ключ Клавиатуры меню Правка.

В списках Слой и Положение ключа вы можете выбрать слой раскладки и позицию ключа, для которых вы хотите задать данные.

Из списка Функция клавиши вы можете выбрать какая функция будет выполняться при переходе ключа к заданному положению.

Макрос означает, что при переходе к заданному положению ключ будет посылать последовательность скан-кодов. Кроме макроса ключу можно так же задать функцию перехода на слой. При переходе ключа к какому-либо положению можно задать только переход на конкретный слой. Временные переходы на слой и переходы на слой вверх или вниз для ключа задать нельзя.

Поле Коды позволяют задавать последовательность скан-кодов, посылаемых при переходе к заданному положению ключа.

Чтобы задать последовательность скан-кодов для ключа c помощью клавиши [image] или пункта контекстного меню Добавить коды нажатия и отжатия откройте окно ввода скан-кодов. Выберите стандартную клавишу, или введите свою последовательность скан-кодов. В случае если вы хотите добавить только коды нажатия(make коды) или коды отжатия(break коды), выберите пункт контекстного меню Добавить коды нажатия или Добавить коды отжатия соответственно.

Поле Звук служит для установки звукового сигнала ключу.

Для задания звукового сигнала ключу необходимо

  1. С помощью клавиши [image] перейти к окну редактирования звукового сигнала.

  2. В появившемся окне вы можете ввести свою последовательность нот или открыть уже готовую последовательность, сохранить и прослушать последовательность нот.

Флаг Блокировка клавиатуры разрешена означает, если он отмечен, что при переходе к данному положению ключа, клавиатура не будет посылать скан-коды при нажатиях клавиш.

2.5. Программирование считывателя

2.5.1. Считыватель магнитных карт

Считывателю магнитных карт можно задать последовательности скан-кодов, посылаемые до и после считанного трека, задать какие треки карты должны считываться, установить звуковой сигнал при считывании. Задание данных для считывателя осуществляется в окне Считыватель магнитных карт.

Чтобы открыть окно Считыватель магнитных карт выберите пункт Считыватель магнитных карт в меню Правка.

Рисунок 7. Окно Считыватель магнитных карт. Закладка Общие

Окно Считыватель магнитных карт. Закладка Общие

Выбрать слой раскладки, в котором вы хотите задать данные для считывателя можно в списке в левой части окна.

Указать какие треки должны быть считаны с карты можно поставив галочку напротив номеров этих треков.

Галочка напротив флага Блокировка при ошибке означает что при ошибке чтения какого-либо трека, считывание информации прекратится и информация не будет передана в компьютер. Если пункт не будет отмечен, то в компьютер будет передана та информация, которая была считана, даже если при чтении треков возникли ошибки.

Если пункт Передавать Enter после данных отмечен, то после данных карты будет передан код клавиши Enter.

2.5.2. Префиксы и суффиксы

Префикс – коды, передаваемые перед данными трека.

Суффикс – коды, передаваемые после данных трека.

Значения по умолчанию

  • Трек 1. Префикс “%“, суффикс “?“

  • Трек 2. Префикс “;“, суффикс “?“

Поля Трек 1, Трек 2 и Трек 3 позволяют ввести суффиксы или префиксы для соответствующих треков.

Чтобы задать суффикс или префикс для нужного трека c помощью клавиши [image] или пункта контекстного меню Добавить коды нажатия и отжатия откройте окно ввода скан-кодов. Выберите стандартную клавишу, или введите свою последовательность скан-кодов. В случае если вы хотите добавить только коды нажатия(make коды) или коды отжатия(break коды), выберите пункт контекстного меню Добавить коды нажатия или Добавить коды отжатия соответственно.

2.5.3. Установка звукового сигнала

На вкладке Звуки можно задать звуковой сигнал, издаваемый клавиатурой при считывании карточки.

Для задания звукового сигнала считывателю необходимо

  1. С помощью клавиши [image] перейти к окну редактирования звукового сигнала.

  2. В появившемся окне вы можете ввести свою последовательность нот или открыть уже готовую последовательность, сохранить и прослушать последовательность нот.

2.6. Группы клавиш

Группы клавиш предназначены для программирования двойных и четвертных клавиш. Группа клавиш выделяется черным контуром.

Чтобы сгруппировать клавиши произведите следующие действия:

  1. Выделите несколько клавиш.

  2. В меню Правка выберите пункт Сгруппировать.

Чтобы разгруппировать клавиши произведите следующие действия:

  1. Выделите несколько клавиш.

  2. В меню Правка выберите пункт Разгруппировать.

В комплекте прилагаются двойные и четвертные клавиши, которые обозначают группу непосредственно на клавиатуре.

2.7. Редактирование изображений клавиш

Редактировать рисунки и надписи для клавиш можно в режиме отображения рисунков. Перейти в данный режим можно из меню Вид, подменю Режим отображения, пункт Показать рисунки.

Рисунок 8. Вид раскладки в режиме отображения рисунков.

Вид раскладки в режиме отображения рисунков.

Открыть окно редактирования изображения и текста клавиши можно либо двойным нажатием левой кнопки мыши на выделенную клавишу, либо выбрав пункт Свойства контекстного меню, появляющегося по нажатию на правую кнопку мыши, либо нажав на кнопку «Клавиша» на панели инструментов. Для работы с рисунками предусмотрены кнопки Загрузить (загрузка изображения в поле Картинка ), Сохранить (сохранение изображения из поля Картинка в заданный файл) и Очистить (очистка поля Картинка ). Для редактирования текста предназначены кнопки Шрифт и Фон , а также флаг расположения надписи.

Рисунок 9. Окно редактирования рисунков клавиш.

Окно редактирования рисунков клавиш.

Пред. |  | След.
KBEditor | Начало | 3. Работа с клавиатурой


3. Работа с клавиатурой
Пред. След.

3. Работа с клавиатурой

Программа KBEditor предоставляет следующие функции работы с клавиатурой:

  • Получение информации о подключенной клавиатуре

  • Тест клавиатуры

  • Чтение раскладки из клавиатуры

  • Запись раскладки в клавиатуру

  • Запись программы в клавиатуру

3.1. Информации о клавиатуре

Чтобы получить информацию о подключенной клавиатуре выберите пункт Информация об устройстве меню Устройство .

Рисунок 10. Окно информации о клавиатуре.

Окно информации о клавиатуре.

В окне информации об устройстве выводится:

  • Версия программы клавиатуры.

  • Версия загрузчика клавиатуры.

  • Объем памяти в байтах.

  • Тип устройства (модель клавиатуры).

  • Количество слоев раскладки.

  • Номера присутствующих треков считывателя.

  • Количество клавиш программируемой клавиатуры.

  • Количество положений ключа.

3.2. Тест клавиатуры

Чтобы узнать какие коды посылает данная клавиша:

  1. В меню Устройство выберите пункт Тест клавиатуры.

  2. Нажмите клавишу клавиатуры, посылаемые scan-коды которой вы хотите узнать.

  3. После нажатия клавиши в окно Тест клавиатуры будут выведены посылаемые клавиатурой scan-коды.

3.3. Чтение раскладки

Выберите пункт Чтение раскладки меню Устройство.

3.4. Загрузка раскладки

Выберите пункт Загрузка раскладки меню Устройство.

3.5. Запись программы

Данная функция позволяет обновлять исполняемую программу клавиатуры.

Чтобы записать программу в клавиатуру:

  1. Загрузите новую версию программы с сайта «Штрих-М»

  2. Выберите пункт Запись программы процессора меню Устройство.

  3. В появившемся диалоге выберите нужный файл программы.

  4. После этого начнется процесс записи файла программы в клавиатуру.

Пред. |  | След.
2. Работа с программой | Начало | 4. Приложения


4. Приложения
Пред. След.

4. Приложения

4.1. Список нот

Таблица 2.

 | До | До Диез | Ре | Ре Диез | Ми | Фа | Фа Диез | Соль | Соль Диез | Ля | Ля Диез | Си
 | C | Cis | D | Dis | E | F | Fis | G | Gis | A | Ais | B
 | C_0 | Cis_0 | D_0 | Dis_0 | E_0 | F_0 | Fis_0 | G_0 | Gis_0 | A_0 | Ais_0 | B_0
Малая октава | C0 | Cis0 | D0 | Dis0 | E0 | F0 | Fis0 | G0 | Gis0 | A0 | Ais0 | B0
Первая октава | C1 | Cis1 | D1 | Dis1 | E1 | F1 | Fis1 | G1 | Gis1 | A1 | Ais1 | B1
Вторая октава | C2 | Cis2 | D2 | Dis2 | E2 | F2 | Fis2 | G2 | Gis2 | A2 | Ais2 | B2
Третья октава | C3 | Cis3 | D3 | Dis3 | E3 | F3 | Fis3 | G3 | Gis3 | A3 | Ais3 | B3
Четвертая октава | C4 | Cis4 | D4 | Dis4 | E4 | F4 | Fis4 | G4 | Gis4 | A4 | Ais4 | B4

4.2. Комплектация

Таблица 3. Для клавиатур с 60-ю клавишами

Наименование | Шт.
Клавиатура | 1
Четвертных клавиш | 2
Двойных клавиш | 4
Одинарных клавиш | 60
Экстрактор клавиш | 1
Диск с программой "Редактор раскладки" | 1
Документация | 1

Таблица 4. Для клавиатур с 64-я клавишами

Наименование | Шт.
Клавиатура | 1
Четвертных клавиш | 2
Двойных клавиш | 6
Одинарных клавиш | 64
Экстрактор клавиш | 1
Диск с программой "Редактор раскладки" | 1
Документация | 1

Таблица 5. Для клавиатур со 112-ю клавишами

Наименование | Шт.
Клавиатура | 1
Четвертных клавиш | 2
Двойных клавиш | 4
Одинарных клавиш | 112
Экстрактор клавиш | 1
Диск с программой "Редактор раскладки" | 1
Документация | 1

4.3. Представление скан-кодов

Таблица 6. Таблица обозначений клавиш (управляющие клавиши):

Backspace | Backspace
Space | Пробел
Tab | Таб
CAPS | CapsLock
LShift | Левый Shift
LCtrl | Левый Control
LWin | Левая клавиша со значком Windows
RAlt | Правый Alt
RShift | Правый Shift
RCtrl | Правый Control
RWin | Правая клавиша со значком Windows
RAlt | Правый Alt
APPS | Клавиша со значком меню
ENTER | Ввод
ESC | Escape
PrintScrn | Print Scrin
Scroll | Scroll Lock
Pause/Break | Пауза
Up | Стрелка вверх
Down | Стрелка вниз
Left | Стрелка влево
Right | Стрелка вправо

Пример: строка “+LCtrl +ENTER +Space -ENTER -Space -LCtrl” обозначает нажатие левого Control’а, нажатие Ввода, нажатие пробела, отжатие Ввода, отжатие пробела, отжатие левого Control’a.

Если цифра или символ находится в угловых скобках (например <5> или <->), то это означает, что эта клавиша на NumPad’е.

Пред. |  | След.
3. Работа с клавиатурой | Начало | 5. Контактная информация


5. Контактная информация
Пред.

5. Контактная информация

НТЦ «Штрих-М»

  • http://www.shtrih-m.ru/

  • <info@shtrih-m.ru>

  • 115280, г. Москва, ул. Мастеркова, д. 4, НТЦ «Штрих-М»

  • Служба поддержки и технических консультаций

    • Техническая поддержка пользователей программных продуктов «Штрих М». Решение проблем, возникающих во время эксплуатации торгового оборудования (ККМ, принтеров, сканеров, терминалов и т.п.) и программного обеспечения (от тестовых программ и драйверов до программно-аппаратных комплексов).

    • Телефон:(095) 787-6096, 787-6090 (многоканальный)

    • E-mail:<support@shtrih-m.ru>

  • Отдел продаж

    • Отдел по работе с клиентами, оформление продаж и документов, информация о наличии товаров.

    • Телефон:(095) 787-6090 (многоканальный)

    • Телефон/факс:(095) 787-6099

    • E-mail:<sales@shtrih-m.ru>

  • Отдел маркетинга

    • Отдел по работе с партнерами «Штрих М» и крупными клиентами.

    • Телефон:(095) 787-6098, 787-6090 (многоканальный)

    • Телефон/факс:(095) 787-6099

    • E-mail:<market@shtrih-m.ru>

  • Отдел разработки

    • Отдел разработки программных (драйверы, программы и т.д.) и аппаратных (ККМ, весы, MemoPlus и прочее) продуктов, предлагаемых фирмой «Штрих М».

    • E-mail:<developer@shtrih-m.ru>

  • Отдел разработки

    • Консультации по вопросам, связанным с торговым оборудованием, программным обеспечением, их интеграцией и внедрением.

    • E-mail:<vnedr@shtrih-m.ru>

Все ваши пожелания можно оставлять на форуме фирмы в разделе «Предложения по доработке продуктов ШТРИХ-М». В этом разделе создана тема «Предложения по доработке редактора раскладок (KBEditor)» для всех предложений по доработке данной программы.

Пред. |
4. Приложения | Начало